Skip to main content
Delphix

VMWare and Delphix - Frequently Asked Questions (KBA1305)

 

KBA

KBA#1305

Applicable Delphix Versions

Click here to view the versions of the Delphix engine to which this article applies
Major Release All Sub Releases
6.0 6.0.0.0, 6.0.1.0, 6.0.1.1, 6.0.2.0, 6.0.2.1, 6.0.3.0, 6.0.3.1, 6.0.4.0, 6.0.4.1, 6.0.4.2, 6.0.5.0, 6.0.6.0, 6.0.6.1, 6.0.7.0, 6.0.8.0, 6.0.8.1, 6.0.9.0, 6.0.10.0, 6.0.10.1, 6.0.11.0, 6.0.12.0, 6.0.12.1

5.3

5.3.0.0, 5.3.0.1, 5.3.0.2, 5.3.0.3, 5.3.1.0, 5.3.1.1, 5.3.1.2, 5.3.2.0, 5.3.3.0, 5.3.3.1, 5.3.4.0, 5.3.5.0, 5.3.6.0, 5.3.7.0, 5.3.7.1, 5.3.8.0, 5.3.8.1, 5.3.9.0

5.2

5.2.2.0, 5.2.2.1, 5.2.3.0, 5.2.4.0, 5.2.5.0, 5.2.5.1, 5.2.6.0, 5.2.6.1

5.1

5.1.0.0, 5.1.1.0, 5.1.2.0, 5.1.3.0, 5.1.4.0, 5.1.5.0, 5.1.5.1, 5.1.6.0, 5.1.7.0, 5.1.8.0, 5.1.8.1, 5.1.9.0, 5.1.10.0

5.0

5.0.1.0, 5.0.1.1, 5.0.2.0, 5.0.2.1, 5.0.2.2, 5.0.2.3, 5.0.3.0, 5.0.3.1, 5.0.4.0, 5.0.4.1, 5.0.5.0, 5.0.5.1, 5.0.5.2, 5.0.5.3, 5.0.5.4

FAQs

Q: We are upgrading to a newer release of ESXi.  Can we also upgrade the hardware (HW) version of the Delphix engine VM? 

Delphix does not have any requirements relating to the virtual hardware version of the Delphix engine virtual machine.  All virtual hardware versions available in each supported release of ESXi are supported for the Delphix engine VM.  The hardware version of the VM can therefore be upgraded if a new feature is needed although upgrading the HW version is not required by Delphix. 

Q: What is the difference between HWv7 and HWv8?

HWv7 runs on ESX4.x and ESX5.1 or later. HWv8 runs on ESX 5.1 or later only. HWv7 may be preferable if the customer is running Delphix in a mixed cluster of vSphere 4.x and later versions.

Additionally, HWv8 has two main features that could impact the Delphix virtual machine.
 
The first is support for > 256GM of RAM for the VM. If the you are not planning to use more than 256GB of RAM or don't have a vSphere license that can utilize that amount of memory, there is no need to move version 8 when a you upgrade from ESX4.x to ESX5.1 or later.
 
The second is support for > 8 vCPUs per VM. If the you have no need for more than 8 vCPUs or don't have a vSphere license or Delphix license to allow more than 8vCPUs, there is no need to move version 8 when you upgrade from ESX4.x to ESX5.1 or later.
 

Q: What are the best settings for ESX and Delphix?

Table: Heap Values and Maximum Storage Sizes

Version Minimum heap value Default value of maximum heap value Maximum heap value Default open VMDK storage per host Maximum open VMDK storage per host
ESXi/ESX 4.0 N/A 16MB 128MB 4TB 32TB
ESXi/ESX 4.1 N/A 80MB 128MB 8TB 32TB
ESXi 5.0 Build 914586 and
earlier 
N/A 80MB 256MB 8TB 25TB
ESXi 5.0 Build 1024429 and
later 
256MB 640MB 640MB 60TB 60TB
ESXi 5.1 Build 914609 and
earlier 
N/A 80MB 256MB 8TB 25TB
ESXi 5.1 Build 1065491 and
later 
256MB 640MB 640MB 60TB 60TB
ESXi 5.5 N/A N/A 256MB 64TB 64TB

For more information please see VMware Heap Exhaustion.

From ESXi 5.5 onwards, the amount of addressable VMFS storage no longer depends upon the VMFS heap size, as described in Understanding the VMFS heap eviction process in ESXi 5.5 and later (2077898).

Q: Does a Delphix engine VM support the use of vMotion?

Yes, both vMotion and Storage vMotion can be used with a Delphix engine VM.  See Additional VMware Configuration Notes.

Q: Can the version of VMware Tools be upgraded on a Delphix engine VM?

VMware Tools is included as part of the Delphix engine VM image and is upgraded, when needed, as part of the normal Delphix engine upgrade process.  VMware Tools cannot be upgraded independently of an engine upgrade.